Table of Contents

Avvio rapido dello sviluppo EasyAR Mega Unity con un esempio

Questa guida spiega come configurare ed eseguire l'esempio EasyAR Mega Unity per iniziare rapidamente lo sviluppo con EasyAR Mega.

Prima di iniziare

Prima di leggere questa guida, assicurarsi di aver completato quanto segue:

  • avere una cloud localization library valida
  • aver installato Unity (2021.3.30 LTS o successiva); si consiglia l'ultima versione di Unity 2022.3 o Unity 6.3
  • aver importato i package com.easyar.sense-**.tgz e com.easyar.mega-**.tgz seguendo Abilitare Mega
Nota

Questa guida si applica solo alla versione >= 4003 del plugin Unity. Se avete scaricato una versione vecchia ma state leggendo la guida introduttiva, prima scaricate l'ultima versione del plugin.

Come usare l'esempio (sei passi)

Di seguito vengono illustrati in sei passaggi i punti fondamentali per configurare ed eseguire l'esempio MegaBlock_Basic.

Passo uno: importare l'esempio

Nota

Se avete importato tutti gli esempi tramite **All Samples**, saltate questo passaggio.

  1. Dal menu Window > Package Manager, aprire Package Manager, selezionare EasyAR Sense Unity Plugin e, nella sezione Samples a destra, espandere tutti gli esempi.
  2. Selezionare l'esempio, ad esempio MegaBlock_Basic, e fare clic su Import.

Import Sample

Nota
  • Questa guida non si applica direttamente ai dispositivi headset, ma prima di sviluppare per headset è utile capire il flusso sviluppando su telefono.
  • Se avevate già importato gli esempi di una vecchia SDK, dopo l'aggiornamento eliminate prima i vecchi esempi e poi reimportateli.

Passo due: configurare SDK e servizio di localizzazione cloud Mega

  1. Nel menu scegliete EasyAR > Sense > Configuration;
    License Guide

  2. Nel pannello Project Settings aperto, incollate la vostra License Key;
    Fill License

    Consiglio

    La EasyAR Sense License può essere creata dal EasyAR Developer Center. Per il primo utilizzo, seguire questi passaggi:

    • Creare EasyAR Sense 4.x Personal
    • Per sparse-space-map selezionare No
    • Il nome dell'applicazione può essere qualsiasi; per Bundle ID e Package Name usare com.mycompany.myproject
    • Selezionare la license appena creata e fare clic sul pulsante di copia a destra

    copykey

    Nota

    Bundle ID e Package Name possono essere modificati in seguito, ma le modifiche sono limitate. Se avete un package name preciso, potete inserire il vostro.

    Non c'è limite al numero di license personali. Gli altri tipi possono essere creati secondo necessità per uso ufficiale.

  3. Verificate e abilitate l'opzione Mega > Mega Block/Landmark support nel pannello Project Settings;

  4. Configurate le informazioni della vostra cloud localization library Mega nell'elemento Mega Block del pannello Project Settings;
    Mega Config Guide

    Consiglio

    La configurazione della cloud localization library Mega può essere ottenuta dal EasyAR Developer Center.
    Mega Config Detail
    Assicuratevi che la vostra API Key abbia i permessi Mega Block e SpatialMap; in caso contrario, modificatela o ricrearla.
    API Key Auth
    Se non riuscite a trovare la library di localizzazione, prima configuratela correttamente e controllate di nuovo che la cloud localization library sia valida.

Passo tre: configurare Mega Block

  1. Configurare Mega Block;

    Selezionare Mega Block e compilare ID e Name del Block.

    Consiglio

    Block ID e Name si possono ottenere dalla relativa localization library nel EasyAR Developer Center.

    Se nella library di localizzazione non ci sono dati Block, è necessario aggiungere il Block richiesto nella localization library e ricontrollare che la cloud localization library sia valida.

Passo quattro: posizionare i contenuti 3D

  1. Selezionare Mega Block e creare lo strumento editor;

  2. Controllare le informazioni del servizio e connettersi al servizio;

    Consiglio

    Se non avete cambiato altro, le informazioni del servizio dovrebbero essere le stesse inserite in Project Settings.

    Dopo la connessione corretta, dovreste vedere l'ora di aggiornamento e l'interfaccia di controllo dei dati dell'editor Block.

  3. Caricare i dati dell'editor Block;

    Fare clic sul primo menu a tendina sotto i dati Block per avviare il caricamento dei dati dell'editor; una volta caricato, la mesh del Block corrente sarà visibile nella finestra Scene:

    Consiglio

    La mesh Block cambia LOD in base alla posizione della camera, quindi è necessario restare connessi.

  4. Posizionare i contenuti 3D

    A questo punto, si può usare la mesh Block come riferimento per posizionare gli oggetti 3D.

    Nota
    • Gli oggetti 3D devono essere posizionati sotto il nodo Block per garantire che il rendering del contenuto virtuale a runtime sia corretto.
    • Gli oggetti 3D non possono essere posizionati sotto il nodo EasyAR.Mega.EditorTool; questo nodo è usato solo per gli strumenti dell'editor e in alcuni casi viene eliminato o ricreato automaticamente.

Passo cinque: modificare la configurazione del Player

Nel menu Unity File > Build Settings > Player Settings, fare clic sull'icona Android per aprire le impostazioni della piattaforma Android.

switchtoandroid

  • Modificare Package Name in modo che corrisponda al Package Name mostrato nella pagina della License Key

    androidPackageName

    Consiglio

    Ad esempio, se il Package Name inserito durante la creazione della License Key è com.mycompany.myproject, qui il Package Name deve essere com.mycompany.myproject, altrimenti l'esecuzione fallirà.

  • Impostare Minimum API Level su API Level 24 o superiore

    androidAPILevel

  • Impostare Scripting Backend su IL2CPP e selezionare ARM64 in Target Architecture

    androidarm64

Passo sei: compilare ed eseguire

  1. Aggiungere la scena corrente in File > Build Settings o Build Profiles > Scene List;
  2. Passare alla piattaforma di destinazione (ad esempio Android/iOS) e verificare che il nome del package (Bundle ID) corrisponda alla License Key;
    Switch Platform
  3. Fare clic su Build And Run.
    Build And Run

L'effetto reale in loco è il seguente:

Sul testo giallo sullo schermo

Durante l'esecuzione potreste vedere due testi gialli sullo schermo.

  1. Messaggio di avviso per esecuzione simulata

    Si trova nella parte inferiore dello schermo:

    Questo avviso compare perché, con la configurazione predefinita, l'app può essere eseguita anche fuori sede. Influisce solo in minima parte sul risultato dell'app; se siete effettivamente sul posto, prima della build potete modificare la configurazione di MegaTracker.

  2. Informazioni di diagnostica

    Si trovano nella parte superiore dello schermo e servono per conoscere lo stato della sessione e i problemi; si consiglia di lasciarle visibili durante sviluppo e test:

    Si può fare riferimento a Informazioni di diagnostica nella scena per capire rapidamente come configurarle e usarle.

Passo successivo: da base a avanzato

Congratulazioni! Con i passaggi sopra avete eseguito con successo l'esempio principale di EasyAR Mega in 10 minuti, sperimentando in prima persona il fascino della localizzazione spaziale e della sovrapposizione di contenuti AR.

Ora avete le basi. Se volete:

  • costruire app AR più stabili ed efficienti
  • realizzare effetti complessi come occlusione realtà/virtuale e allineamento dei contenuti
  • fare debug quando non avete il dispositivo o non potete andare sul posto

fate riferimento alle guide approfondite seguenti, che vi aiuteranno a risolvere problemi reali di sviluppo.

Avanzamento nello sviluppo

Se volete conoscere la configurazione completa del progetto, potete consultare:

Se volete capire meglio come usare EasyAR, potete partire da qui:

Si consiglia inoltre di leggere quanto segue per sviluppo e debug:

Controllo fine delle funzionalità Mega

I seguenti contenuti vi aiuteranno a usare meglio Mega nella vostra app:

I seguenti contenuti vi aiuteranno a verificare le funzionalità Mega senza andare sul posto:

Argomenti avanzati

I contenuti seguenti sono più adatti a chi ha già una certa esperienza con EasyAR.

Se volete eseguire EasyAR Mega su headset, potete consultare:

Se volete usare AR Foundation, potete iniziare da qui: